Is it possible to use a different name for the message in JSON source?

Hi Guys,

We faced a problem. The framework that we use generates the source file looks like this:

  "account-created.button": {
    "defaultMessage": "Back to Site",
    "description": "Button on the create user page"

It is the JSON format with Mozilla/Chrome i18n features. The framework provides only this structure, and can’t use message , string , text , value , content , translation. as a message field.

Is it possible to use any transformation to replace “defaultMessage” with “message” in uploads action? I’ve found nothing about that in the documentation.

Hi @Yakimov_Vladimir,
what framework is that?

@vaclav any ideas?

And the message declaration page in the documentation.

Hello, sorry I missed this topic.

We will add defaultMessage too. It will be available soon (today/tomorrow).

It should be a simple change.