CLI in Windows add to path


It’s been a break in our project, so it’s been a while since I used localazy. But, setting up Localazy CLI on Windows, downloading the localazy.exe file and adding it to path doesn’t seem to work.

In other words localazy [command] doesn’t work in the terminal, I have to use the full path to the exe. I might remember incorrectly, but I a 90% sure this worked before? Adding the exe to the system path and then it was globally available.

Or? Do I remember wrong.

Isn’t it necessary to use the whole localazy.exe even if it’s in the system path?

We tend to use localazy [command] everywhere as it’s working on both Linux and macOS. But, of course, there may be some differences on Windows. The same applies to path separators, etc.

We suggest to use localazy.exe in the installation guide as well: CLI: Installation | Localazy Docs

Maybe, @dan will be able to answer better as I don’t use Windows for ages :-).

As mentioned, I am using localazy.exe, the whole thing :wink: But adding it to system path doesn’t work, it still requires the full path to the file to use it, instead of just localazy.

Same thing with node, you would have to use the full path to node to use it, until you add it in the system path, it then becomes globally available by just using node instead of C:\node\node.exe

The main problem is that I have a make file that handles the locales for me, when I can’t use a global command like localazy, but have to use a custom path, then I can’t make the make file function universally between all operating systems or development environments. Each developer would have to change the make file to set their own localazy path.

I see. However, it seems to be a misconfiguration of the system paths. If it works for node, it should do for our executable as well.

From this point of view, localazy.exe is a standard Windows binary. Nothing prevents it from being called as all other commands available on the system path.

Well, there is


Not sure as Windows is not my cup of tea, but all paths are pointing to directories while the last record is pointing to the executable file.

Maybe, the last line should read C:\laragon\bin only?

Odd, but adding the folder to path instead of the exe worked, pretty sure it hasn’t been like that before.

1 Like